home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-boot / grub-0.96-r2 / grub-0.96-r2.ebuild < prev    next >
Text File  |  2006-03-30  |  4KB  |  148 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.10 2006/02/05 14:44:52 blubb Exp $
  4.  
  5. inherit mount-boot eutils flag-o-matic toolchain-funcs
  6.  
  7. PATCHVER=0.1
  8. DESCRIPTION="GNU GRUB boot loader"
  9. HOMEPAGE="http://www.gnu.org/software/grub/"
  10. SRC_URI="mirror://gentoo/${P}.tar.gz
  11.     ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
  12.     http://dev.gentoo.org/~seemant/distfiles/${PF}-gentoo-${PATCHVER}.tar.bz2
  13.     http://dev.gentoo.org/~seemant/distfiles/splash.xpm.gz
  14.     mirror://gentoo/splash.xpm.gz
  15.     mirror://gentoo/${PF}-gentoo-${PATCHVER}.tar.bz2"
  16.  
  17. LICENSE="GPL-2"
  18. SLOT="0"
  19. KEYWORDS="amd64 x86"
  20. IUSE="static netboot custom-cflags"
  21.  
  22. RDEPEND=">=sys-libs/ncurses-5.2-r5"
  23. DEPEND="${RDEPEND}
  24.     >=sys-devel/automake-1.7
  25.     >=sys-devel/autoconf-2.5"
  26. PROVIDE="virtual/bootloader"
  27.  
  28. PATCHDIR="${WORKDIR}/gentoo"
  29.  
  30. pkg_setup() {
  31.     if use amd64; then
  32.         ABI_ALLOW="x86"
  33.         ABI="x86"
  34.     fi
  35. }
  36.  
  37. src_unpack() {
  38.     unpack ${A} ; cd "${S}"
  39.  
  40.     EPATCH_SUFFIX="patch"
  41.     epatch ${PATCHDIR}
  42.  
  43.     # a bunch of patches apply to raw autotool files
  44.     autoconf || die "autoconf failed"
  45.     aclocal || die "aclocal failed"
  46.     automake || die "automake failed"
  47. }
  48.  
  49. src_compile() {
  50.     unset BLOCK_SIZE #73499
  51.  
  52.     ### i686-specific code in the boot loader is a bad idea; disabling to ensure
  53.     ### at least some compatibility if the hard drive is moved to an older or
  54.     ### incompatible system.
  55.  
  56.     # grub-0.95 added -fno-stack-protector detection, to disable ssp for stage2,
  57.     # but the objcopy's (faulty) test fails if -fstack-protector is default.
  58.     # create a cache telling configure that objcopy is ok, and add -C to econf
  59.     # to make use of the cache.
  60.     #
  61.     # CFLAGS has to be undefined running econf, else -fno-stack-protector detection fails.
  62.     # STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
  63.     # -fno-stack-protector detected by configure, removed from netboot's emake.
  64.     use custom-cflags || unset CFLAGS
  65.  
  66.     export grub_cv_prog_objcopy_absolute=yes #79734
  67.     use static && append-ldflags -static
  68.  
  69.     # build the net-bootable grub first, but only if "netboot" is set
  70.     if use netboot ; then
  71.         econf \
  72.         --libdir=/lib \
  73.         --datadir=/usr/lib/grub \
  74.         --exec-prefix=/ \
  75.         --disable-auto-linux-mem-opt \
  76.         --enable-diskless \
  77.         --enable-{3c{5{03,07,09,29,95},90x},cs89x0,davicom,depca,eepro{,100}} \
  78.         --enable-{epic100,exos205,ni5210,lance,ne2100,ni{50,65}10,natsemi} \
  79.         --enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
  80.         --enable-{tulip,via-rhine,w89c840} || die "netboot econf failed"
  81.  
  82.         emake w89c840_o_CFLAGS="-O" || die "making netboot stuff"
  83.  
  84.         mv -f stage2/{nbgrub,pxegrub} "${S}"/
  85.         mv -f stage2/stage2 stage2/stage2.netboot
  86.  
  87.         make clean || die "make clean failed"
  88.     fi
  89.  
  90.     # Now build the regular grub
  91.     # Note that FFS and UFS2 support are broken for now - stage1_5 files too big
  92.     econf \
  93.         --libdir=/lib \
  94.         --datadir=/usr/lib/grub \
  95.         --exec-prefix=/ \
  96.         --disable-auto-linux-mem-opt || die "econf failed"
  97.     emake || die "making regular stuff"
  98. }
  99.  
  100. src_test() {
  101.     # non-default block size also give false pass/fails.
  102.     unset BLOCK_SIZE
  103.     make check || die "make check failed"
  104. }
  105.  
  106. src_install() {
  107.     make DESTDIR="${D}" install || die
  108.     exeinto /usr/lib/grub/${CHOST}
  109.     use netboot && doexe nbgrub pxegrub stage2/stage2.netboot
  110.  
  111.     insinto /boot/grub
  112.     doins ${DISTDIR}/splash.xpm.gz
  113.     newins docs/menu.lst grub.conf.sample
  114.  
  115.     dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
  116.     newdoc docs/menu.lst grub.conf.sample
  117.  
  118.     docinto gentoo
  119.     dodoc ${PATCHDIR}/README*
  120. }
  121.  
  122. pkg_postinst() {
  123.     [[ ${ROOT} != "/" ]] && return 0
  124.  
  125.     # change menu.lst to grub.conf
  126.     if [[ ! -e /boot/grub/grub.conf && -e /boot/grub/menu.lst ]] ; then
  127.         mv -f /boot/grub/menu.lst /boot/grub/grub.conf
  128.         ewarn
  129.         ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
  130.         ewarn
  131.     fi
  132.     einfo "Linking from new grub.conf name to menu.lst"
  133.     [[ ! -e /boot/grub/menu.lst ]] && ln -snf grub.conf /boot/grub/menu.lst
  134.  
  135.     [[ -e /boot/grub/stage2 ]] && mv /boot/grub/stage2{,.old}
  136.  
  137.     einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
  138.     for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
  139.         [[ -f ${x} ]] && cp -p ${x} /boot/grub
  140.     done
  141.  
  142.     [[ -e /boot/grub/grub.conf ]] \
  143.         && /sbin/grub \
  144.             --batch \
  145.             --device-map=/boot/grub/device.map \
  146.             < /boot/grub/grub.conf > /dev/null 2>&1
  147. }
  148.